Initial Portfolio balance not reflected in results

respond2you
Posts: 4
Joined: Tue Jun 21, 2016 2:29 am

Initial Portfolio balance not reflected in results

Postby respond2you » Tue Jun 21, 2016 7:46 am

Many of the starting balances in the portfolios are much higher than the actual amount specified, which means the success results are essentially useless.

See Saved Sim 1861 (that also shows the $0 spending bug). It's showed up in every other sim I've seen since I noticed it.

This seems to be a "sev 1" bug making the whole calculator useless.

Help!!

Thanks,
r2u

ERD50
Posts: 200
Joined: Tue Jul 02, 2013 12:50 am

Re: Initial Portfolio balance not reflected in results

Postby ERD50 » Wed Jun 22, 2016 3:22 am

Is that just a reflection of a positive market (growth is larger than any withdraws)?

That's common, and I think what you are seeing is not the "starting portfolio" but the portfolio at the end of the first year.

-ERD50

respond2you
Posts: 4
Joined: Tue Jun 21, 2016 2:29 am

Re: Initial Portfolio balance not reflected in results

Postby respond2you » Wed Jun 22, 2016 5:42 am

Yep ERD--that's exactly it. It takes the portfolio value, augments it by growth, and the deducts the initial spending.

So basically, it assumes that we live the first retirement year on funds *not* in the retirement portfolio.

That's a very confusing assumption, and means we have set aside other funds to use that first year. Or alternately, the "initial year spending" is actually "income for living off year 2".

Not as bad as I thought, but certainly not the most useful assumption.

ERD50
Posts: 200
Joined: Tue Jul 02, 2013 12:50 am

Re: Initial Portfolio balance not reflected in results

Postby ERD50 » Wed Jun 22, 2016 12:54 pm

I can't view your saved sims, I think only you (and maybe bo_knows) can.

But I used defaults, ran a single cycle for 1995, and downloaded the spreadsheet. I think everything looks fine. The graph is showing year end values, and I think this is the source of your confusion.

For example. 1995 starts as $1,000,000, but after subtracting $40,000 spend and $2,241 fees, and adding $230,849 equities.growth, $20,397 dividends, $53,978 bonds.growth, you get:

portfolio.end
$1,262,983 ( $1 rounding to $1,262,982?)

And that is what the graph shows when you mouse over it. So it looks right to me - do you see a problem, considering this?

edit/add - OK, I think I see what you are saying now - are the expenses taken out at the beginning of the year (so growth should be calculated on $960,000?), or taken out at the end of the year (after growth)? If the second case, I suppose you are right - the retiree would be living off 'borrowed money' and paying it back year end. I'd have to look more closely at the raw data (or maybe run a 0% inflation, fixed yield scenario for an easier test).

In reality, one could take the money out each month/week/quarter, but the start of the year is probably cleanest assumption for a tool like this. But maybe that is done, I don't know.

-ERD50

respond2you
Posts: 4
Joined: Tue Jun 21, 2016 2:29 am

Re: Initial Portfolio balance not reflected in results

Postby respond2you » Mon Jul 11, 2016 3:49 pm

Hi ERD--I guess in using the calculator, the money for the first year has to be in cash already outside the sim's knowledge.

Otherwise, it will exaggerate the gains in a good year and exaggerate the losses in a bad year, and that first year has a great deal to do with how the portfolio does overall.

It does seem inconsistent, since the money for year X is withdrawn just before year X+1, but it doesn't appear to withdraw enough money to live on in year X+1 because of inflation.

It is a challenge, since it's unlikely that I would withdraw all the money to live on for a year on Jan 1. But that is far more likely than me withdrawing it all on Dec 31 and living off it retroactively.

I'll submit a bug in the git hub eventually for this, giving some time for enlightenment...


Return to “cFIREsim Bugs”

Who is online

Users browsing this forum: No registered users and 3 guests