Page 1 of 1

Newbie UI Problem on Solution popup

Posted: Sat Apr 16, 2016 5:06 pm
by tangofan
Hi all,

First of all as a newbie to this forum I'd like to say a big "thank you" to the creator(s) of this tool, it is a fantastic resource.

As a newbie to the tool, I am running into some problem with the UI. If I am missing something obvious, please let me know.

Each time I am running a simulation it opens a new "tab" on the simulation popup and it keeps the previous tabs for reference. So far so good...
However the number of tabs seems to be a maximum of 10, so if I run the 11th simulation it will only show the result from the 10th simulation and not open a new tab on the popup. (For the record I am using Google Chrome on Windows 10).

I can understand that - for memory and other constraints - you don't want to allow unlimited tabs, but as far as I can tell the tool doesn't even give a warning that it is showing the results for an older simulation.
Furthermore, even if one is aware of this, there is no way (that I could see) to manually close some of the old tabs in order to see the results of your new simulation. Essentially at this point it seems you have to reload the web page and enter all parameters again from scratch.

Assuming that I am not missing something here, it would be nice to have this behave differently:
1. One possibility could be to automatically "drop" the oldest tab, if there are already 10 solutions buffered. E.g. after running simulation #11, the tabs shown will be #2 to #11.
2. It would also be helpful to be able to manually close a tab with a simulation that isn't needed anymore.
3. Or alternatively remember the entered parameters in a cookie, so when reloading the website you don't have to enter everything again. (Admittedly there could be some privacy issues with this).

Thank you in advance for listening.

Re: Newbie UI Problem on Solution popup

Posted: Sat Apr 23, 2016 1:45 am
by bo_knows
Yeah, I assumed that no one would be on the site long enough to go through 10 simulations or more. I'll look to add some functionality to alleviate this issue.